q3a 1.3 requires Mac OS 9.0.4???

edited October 2001 in Gaming

Comments

  • edited December 1969
    Please tell me this is an installer problem.
  • edited December 1969
    Re: q3a 1.3 requires Mac OS 9.0.4???

    Hmm? The OS 9 version probably does. I suspect that the OS X version does not... but then I guess I could be wrong about that, given the wacky dual-OS setup that is involved with OS X. Could you be more specific about what is going on?
  • edited December 1969
    Re: q3a 1.3 requires Mac OS 9.0.4???

    Could you be more specific about what is going on?

    I have Mac os 8.6 installed on my G3. I download the latest update to Q3A. I run the installer. It says "Mac OS 9.0.4 or greater required".

    Huh?

    What in OS 9.0.4 could be required by Quake? I have the latest Game Sprockets and even CarbonLib installed...

    I'm guessing this is a lazy-check-for-requirements problem, where something required by the installer or something required by the game is actually there, but the code only checks the OS version rather than using all the Gestalt calls needed to verify the install.

    I wonder if there's a plain ol' archive out there somehwere that I could use (or is the key encoded in one of the pk3 files?). I bet that given just the updated app and data files (keeping whichever one contains my key), I could run Q3A 1.3 just fine.

    _/ C

  • edited December 1969
    Re: q3a 1.3 requires Mac OS 9.0.4???

    Hmm. Could be. I thought I remembered a Graeme Devine .plan about the reasons a certain OS version was required, but going back to look at that I see that he was talking about the requirement for 10.0.4 with the OS X patch on some systems... nothing mentioned about the OS 9 version except that it was available.

    I know that a while back they made some changes to "make Q3 compatible with OS 9.1". Perhaps those changes made it _un_compatible with previous versions (intentionally or otherwise).
Sign In or Register to comment.